Последняя версия VirtueMart 1.1.5 (русский)

virtuemart-115

В новом релизе исправлена серьзная уязвимость безопасности, а также мелкие баги (но не все - согласно словам авторов, часть багов, обозначенных в bug tracker'е в процессе исправления), переписан модуль оплаты PayPal согласно новому API этой системы, переписан модуль продавца (Merchant Warrior payment module).

Язык: русский

В архиве: ext_com ext_mod ext_plugin ext_lang

Совместим с: compat_15


Скачать VirtueMart 1.1.5 (русский) 5.1 Mb


 

 

Комментарии  

 
+1 # 29.08.2010 04:11
установил компонент, руссифицировал, всё вроде как нормально, но когда начал добавлять категории то, вместо названия выводятся сплошные знаки вопросов.
Подскажите как быть в этой ситуации и что делать
Ответить | Ответить с цитатой | Цитировать
 
 
+1 # Administrator 29.08.2010 09:48
Знаки вопросов говорят, что у вас с кодировкой проблемы.
1) посмотрите в какой кодировке у вас БД, а в какой сайт
2) в базе тоже вопросы сохранились? А то бывают проблемы с выводом (в базе нормально, а при выводе уже сбой)
Ответить | Ответить с цитатой | Цитировать
 
 
+1 # 30.08.2010 09:58
Да в базе тоже вопросы, сайт в utf-8 а в базе в latin1_swedish_ci, что делать как изменить кодировку у всех таблиц VM разом, их там много и не хотелось бы в ручную, да и сам тест тож наверное надо как-то перекодировать
Ответить | Ответить с цитатой | Цитировать
 
 
+3 # Administrator 30.08.2010 15:23
Попробуйте запросами.

ALTER TABLE `ИМЯ ТАБЛИЦЫ` DEFAULT CHARACTER SET utf8 COLLATE utf8_general_ci
Ответить | Ответить с цитатой | Цитировать
 
 
+1 # 31.08.2010 11:52
да это помогло, но частично изменилась кодировка самой таблицы, не подскажите как изменить кодировку полей в таблице?
Ответить | Ответить с цитатой | Цитировать
 
 
+1 # Administrator 31.08.2010 19:31
Не совсем понял, как это "частично изменилась кодировка самой таблицы". Но кодировку поля можно поменять при изменении структуры таблицы. Я не помню как там в PhpMyAdmin'е, я NaviCat юзаю. там можно.
Ответить | Ответить с цитатой | Цитировать
 
 
+1 # 03.09.2010 01:26
я имею ввиду что изменилась кодировка самой таблицы, а кодировка полей в таблице так и осталась latin1_swedish_ci
Ответить | Ответить с цитатой | Цитировать
 
 
+1 # Administrator 03.09.2010 11:57
Ну попробуйте тогда как я написал выше, изменить в режиме дизайна таблицы. Но если честно, как-то это все странно выглядит. У меня нормально все установилось. Хотя всякое может быть и иногда действительно приходится повозиться.
Ответить | Ответить с цитатой | Цитировать
 
 
+1 # Administrator 30.08.2010 15:24
Естественно, предварительно сделайте бэкап базы.
Ответить | Ответить с цитатой | Цитировать
 
 
+1 # Чепова Наталья 24.10.2010 09:15
Приветствую всех! Буду признательна за объяснение как установить русский язык в VirtueMart или как воспользоваться папкой Language_Pack_f or_VirtueMart_1.1.3
Ответить | Ответить с цитатой | Цитировать
 
 
+1 # Administrator 24.10.2010 22:00
Из папки просто копированием ставится.
Ответить | Ответить с цитатой | Цитировать
 
 
+1 # 26.10.2010 17:45
Уважаемый Администратор,я установил компонент, все ОК.Только вот объясните пожалуйста,как русифицировать?Русик у меня есть.
Ответить | Ответить с цитатой | Цитировать
 
 
+1 # Administrator 26.10.2010 19:24
Ответил выше. Если не знаете куда копировать это другой вопрос. Но думаю там по названиям папок можно без труда разобраться.
Ответить | Ответить с цитатой | Цитировать
 
 
+1 # 26.10.2010 20:51
Приветствую всех! Не знаю куда копировать! Если копирую в папку www -ничего не меняется, если копирую в landguage -всё так же. Прошу объяснить, заранее благодарю!
Ответить | Ответить с цитатой | Цитировать
 
 
+5 # Administrator 27.10.2010 16:24
Вот расписал, надеюсь поможет.
www.joomla-only.ru/joomla/382-rusifikaciya-virtuemart-1-1-5.html

Если что - задавайте вопросы, постараюсь ответить. Не стесняемся, все мы учимся. И не нужно мне на почту писать самоуничижитель ных писем. Все мы "Тупые" в каких-то областях, но главное учиться, а не прятаться.
Ответить | Ответить с цитатой | Цитировать
 
 
+1 # 14.11.2010 15:21
Установил VM 1.1.3/ Отображаются ошибки в папке com_virtuemart (типа: Deprecated: Assigning the return value of new by reference is deprecated in Z:\home\joomla\ www\administrat or\components\c om_virtuemart\v ersion.php on line 19). Так же в расширенном виде не отображается шапка и панель администрирован ия VM. Соответственно работать с VM не получается.Как исправить?
Ответить | Ответить с цитатой | Цитировать
 
 
+1 # Administrator 14.11.2010 15:40
Даже не знаю что вам сказать. Тут нужно смотреть, я так на вскидку не могу сказать что у вас. Может версия ПХП не подходит и что-то не работает. попробуйте поставить VM 1.1.5
Ответить | Ответить с цитатой | Цитировать
 
 
+1 # 22.11.2010 05:18
Вот как я поставил русификатор: скачал с официального сайта VirtueMart последнюю сборку с Joomla 1.5 и поставил ее на хост(устанавила сь на английском языке). Далее скачал отдельно дистрибутив Joomla 1.5. Рус и переместил языковые пакеты из папки administrator/language (все копируем и вставляем в аналогичную папку). С русификацией сайта аналогично - language (сайта)все копируем и вставляем в аналогичную папку. Далее скачал русик к VirtueMart и скинул его в: administrator/components/com_virtuemart/languages (только Index.html - удалил)
Вот и все! На сайт ставится магазин с шаблонам, плагинами и модулями. Вам остается только перебить в админке менюшку на русский и материалы сайта!
Всем удачи при инсталляции!!!
Ответить | Ответить с цитатой | Цитировать
 
 
+1 # 25.11.2010 03:41
я установил все как написано выше,но не административна я часть virtualMart ни на сайт virtualmart не русифицировалас ь, подскажите в чем может быть проблема и что изменить?
Ответить | Ответить с цитатой | Цитировать
 
 
+1 # Administrator 25.11.2010 08:04
ну, тут все могут только гадать. может все-таки не все по инструкции, может версия ВМ другая.
Ответить | Ответить с цитатой | Цитировать
 
 
+1 # 26.11.2010 22:58
Не получается поставить это расширение. Через админку установить расширения, указываю архив...сбой операции "Установчный файл не найден". Распаковывал, уснавливал тот, что внутри архива, то же сообщение! в чем может быть дело?
Ответить | Ответить с цитатой | Цитировать
 
 
+1 # Administrator 26.11.2010 23:21
Цитирую Иван85:
Не получается поставить это расширение. Через админку установить расширения, указываю архив...сбой операции "Установчный файл не найден". Распаковывал, уснавливал тот, что внутри архива, то же сообщение! в чем может быть дело?

Могу предположить, что срабатывает ограничение на объем файла. Скопируйте установочник (внутренний) во временную директорию на сервер и установите из нее.
Ответить | Ответить с цитатой | Цитировать
 
 
+1 # 28.11.2010 13:53
Здравствуйте. Никак не могу установить версию 1.1.5 на joomla 1.1.22.
А версия 1.1.4 ставиться без проблем.
Подскажите по шагам, что надо делать.
Ответить | Ответить с цитатой | Цитировать
 
 
+1 # Administrator 28.11.2010 14:04
Цитирую Titan:
Здравствуйте. Никак не могу установить версию 1.1.5 на joomla 1.1.22.
А версия 1.1.4 ставиться без проблем.
Подскажите по шагам, что надо делать.

Хорошо сегодня-завтра напишу как устанавливать. А что конкретно не ставится? что происходит? ошибка какая-то или может замечания выскакивают?
Ответить | Ответить с цитатой | Цитировать
 
 
+1 # 06.12.2010 12:21
Ребят подскажите с проблемкой после установки этого модуля постоянно приходится заново авторизаватся, и колво пользователей увеличивается с каждым входом?
Ответить | Ответить с цитатой | Цитировать
 
 
+2 # Administrator 06.12.2010 12:37
Мне даже представить сложно, что у Вас такое.
Ответить | Ответить с цитатой | Цитировать
 
 
+2 # Коваль Денис Александрович 07.02.2011 20:54
Приветы,такая проблема : установил ВМ , и в процессе настройки стало появляться сообщение :Отладка: Using existing Session 4a2e912bbe86fde17d9310b8b3c67d96, ID: 665338957065693c162431de06526854. в инете очень мало толкового на эту тему, может подкажете че к чему?(((
Ответить | Ответить с цитатой | Цитировать
 
 
+1 # Administrator 07.02.2011 21:03
Не сталкивался с таким, поэтому не могу ничего порекомендовать ((
Ответить | Ответить с цитатой | Цитировать
 
 
+1 # 09.02.2011 19:43
Спасибо, все отлично получилось. Главное .pdf файлик внимательно читать. Там практически все изложенные тут ошибки уже рассмотрены. Банально ненадо боятьяс "многа букаф". Я 4 часа просто готовился к установке, чтобы быть уверенным что ничего не забыл и не пропустил. Сама установка заняла минуту от силы. Зато все работает, и я вообще Joomla! в первый раз ставлю)
Ответить | Ответить с цитатой | Цитировать
 
 
0 # 22.02.2011 15:20
Добрый день!
Проблемма - Установил virtuemart 1.1.5 - вроде все ок - но НЕ ОТКРЫВАЮСЯ ТОВАРЫ! При клике на товар открывается пустое окно. Переустановил joomla - бесполезно. Обновил virtuemart до 1.1.7 - такая же проблемма. В чем же загвоздка?! Может есть идеи - помогите пожалуйста! shop.metroves.ru
Ответить | Ответить с цитатой | Цитировать
 
 
0 # Administrator 22.02.2011 16:40
Включите отображение ошибок и посмотрите что не так
Ответить | Ответить с цитатой | Цитировать
 
 
0 # 24.02.2011 08:43
А как же это сделать?!
Цитирую Administrator:
Включите отображение ошибок и посмотрите что не так
Ответить | Ответить с цитатой | Цитировать
 
 
0 # 22.02.2011 16:46
а ты товары может не добавил или не установил вообще их даже демо?
Ответить | Ответить с цитатой | Цитировать
 
 
0 # 24.02.2011 11:36
Цитирую demiurg:
а ты товары может не добавил или не установил вообще их даже демо?


Нет, товары добавлены! В корзине показываются...а вот карточка товара не отображается...
Ответить | Ответить с цитатой | Цитировать
 
 
0 # 24.02.2011 10:45
http://shop.metroves.ru/index.php?page=shop.product_details&flypage=garden_flypage.tpl&product_id=2&category_id=3&option=com_virtuemart&Itemid=1
- отображение ошибок - что это может значить?!
Ответить | Ответить с цитатой | Цитировать
 
 
0 # Administrator 24.02.2011 10:54
В файле .htaccess пропишите в начале
php_value display_errors 1
php_value error_reporting 7

Если хостер поддерживает, то должны отобразиться ошибки. То что вы включили это отладка джумловая, но она не покажет критические ошибки PHP.

Обратите внимание, что файл должен быть назван .htaccess, т.к. по умолчанию он переименован в джумле
Ответить | Ответить с цитатой | Цитировать
 
 
0 # 24.02.2011 11:46
Parse error: syntax error, unexpected '=', expecting ')' in /home/m/metrovesru/shop/public_html/administrator/components/com_virtuemart/classes/payment/ps_paypal_api.php on line 1397

- при открытии карточки товара.
Ответить | Ответить с цитатой | Цитировать
 
 
0 # Administrator 24.02.2011 11:57
Ну вот вам и подсказка. Смотрите этот файл в примерно 1397 строке. Где-то там ошибка синтаксическая.
Ответить | Ответить с цитатой | Цитировать
 
 
0 # 24.02.2011 12:09
//Createst the NVP string for all items in the cart
function getCartnvpstr( &$order_totals=array() ) {
global $auth, $VM_LANG;
$cart = $_SESSION['cart'];
require_once(CL ASSPATH. 'ps_product.php' );
$ps_product = new ps_product;

$ret_str="";
$item_total = 0;
for ($i=0;$iget_adjuste d_attribute_pri ce($cart[$i]["product_id"], $cart[$i]["description"]);

// Convert to
- это текст, начиная с 1396 строки...может поможете разобраться.
И Как же так получается ни у кого нет этой ошибки, а у меня она вдруг есть?! Может есть аналогичный файл шаблона у кого-нибудь?
Ответить | Ответить с цитатой | Цитировать
 
 
0 # Administrator 24.02.2011 12:37
Визуально ошибки не вижу, но может быть что у Вас Php 4 (хотя вероятность небольшая), или каких-то библиотек не достает. Так трудно сказать
Ответить | Ответить с цитатой | Цитировать
 
 
0 # 24.02.2011 12:30
Большое СПАСИБО! Вывели на проблемный участок. Я просто удалил из списка эту систему оплаты и все заработало!!!
Ответить | Ответить с цитатой | Цитировать
 
 
0 # 07.04.2011 18:28
Напиши подробнее что ты сделал, у меня аналогичная проблема.
Ответить | Ответить с цитатой | Цитировать
 
 
0 # 12.03.2011 01:20
здравствуйте! Устанавливаю из папки, выдаёт следующую ошибку:

Невозможно скопировать выбранный файл.
JInstaller::ins tall: Ошибка при копировании файла: /home/us8913/test/joomla/tmp/frontend_files.tar.gz в /home/us8913/test/joomla/components/com_virtuemart/frontend_files.tar.gz

Решения в интернете толком не нашёл, надеюсь, что Вы подскажете...
Ответить | Ответить с цитатой | Цитировать
 
 
+1 # Administrator 12.03.2011 19:48
Зачастую такие ошибки появляются из-за недостаточности прав. Возможно папка с компонентами не имеет прав на запись.
Ответить | Ответить с цитатой | Цитировать
 
 
0 # Avtrobot 23.08.2011 21:43
Много разных расширений для joomla на сайте http://avtrobot.ru/
Ответить | Ответить с цитатой | Цитировать
 
 
0 # 17.02.2012 01:39
Уважаемый Администратор Ваши слова "не стесняемся" меня подбодрили.решил написать .У меня при нажатии на товар в virtuemart открывается первый добавленный товар с таким же наименованием-думал в этом проблема менял наименование все равно так же .Подскажите пожалуйста
Ответить | Ответить с цитатой | Цитировать
 
 
0 # Administrator 17.02.2012 07:03
Добрый день. Если честно, то сложно тут подсказать не видя пациента. Но могу предположить что у Вас стоит какой-то модуль для СЕО (например, sh404SEF) и так получилось что у товаров одинаковые алиасы, и он редиректит на первый материал.
Ответить | Ответить с цитатой | Цитировать
 
 
0 # 19.03.2012 03:22
Уважаемый Администратор, помогите пожалуйста! Устанавливаю VirtueMart 1.1.5 (версию скачивал с разных мест, результат одинаковый) на Joomla 1.5.23. на локале. Устанавливаю, разархивировав в tmp локал-сайта. Первый этап проходит успешно. Но на следующем этапе - либо загрузить демо, либо перейти в virtuemart - выводится следующее сообщение на желтом фоне:
ERROR
You do not have permission to access the requested module.
Пожалуйста, подскажите, с чем это может быть связано, и как с этим бороться. Заранее благодарен!
Ответить | Ответить с цитатой | Цитировать
 
 
+1 # Administrator 19.03.2012 07:35
Версия 1.1.5 уже устаревшая и в ней используются функции MySQL 5 версии (если не изменяет память), у Вас же наверное более новая и поэтому не корректно происходит инсталляция MySQL. Сделайте тестовую БД и выполните запросы с файла virtuemart.installation.joomla.sql наверняка какие-то выпадут в ошибки, их нужно будет откорректироват ь под реалии вашей БД, обратно сохранить и переинсталлиров ать компонент.
Ответить | Ответить с цитатой | Цитировать
 
 
+1 # 20.03.2012 01:10
Уважаемый Administrator, спасибо за совет и оперативность! Разыскал более новую версию (1.1.9) - установилась без проблем. Большое спасибо! Буду обращаться.
Ответить | Ответить с цитатой | Цитировать
 

Добавить комментарий

Перед публикацией ваш комментарий должен пройти проверку Администратором.


Защитный код
Обновить